Vietnamese Czech English German Japanese

[IMPORTANT] Limited support for IE8, 9 and 10

JoomlArt has an important announcement: Starting today, our templates will have limited support for

JoomlArt has an important announcement: Starting today, our templates will have limited support for Internet Explorer 8, 9 and 10. We will continue to fully support Internet Explorer 11 and the new Edge browser of Microsoft.